Results 1 to 3 of 3

  1. Post
    #1

    I'm scratching my head over this one... Riprep

    Hi guys,

    Im trying to upload an image to a RIS server and all of a sudden im getting the following errors

    Code:
    Can not copy reparse point: C:\WINDOWS\assembly\GAC_MSIL\IEExecRemote\2.0.0.0__b03f5f7f11d50a3a
    Error ignored. Operation continuing.
    
    Can not copy reparse point: C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a
    Error ignored. Operation continuing.
    The lord Google does not reveal much information about this. The image is stuffed and i can't load them onto a new machine.

    I'm feeling very lost on this one.

    Previous happy images reveal that the second path doesn't exist, there is no 2.0.0... path. For the GAC_MSIL path, it is there and there is a file in the folder called IEEcecRemote.dll.

  2. Post
    #2
    Hi Hawkz25,

    I am not 100% sure, I am testing now, but hopefully this will help, it has worked for C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0 _03f5f7f11d50a3a

    In my riprep.sif - I added the entry below:

    [GuiRunOnce]
    "C:\WINDOWS\RISupds\$OEM$\linkit.cmd"

    I created a folder on the server in the image's folder "RISupds\$OEM$" in IMAGENAME\i386\Mirror1\UserData\WINDOWS\
    In there, I placed the following files:
    linkd.exe
    linkit.cmd
    cmdlines.txt

    In cmdlines.txt
    [Command]
    "c:\WINDOWS\RISupds\$OEM$\Linkit.cmd"

    In linkit.cmd
    start /w c:\WINDOWS\RISupds\$OEM$\linkd.exe C:\WINDOWS\assembly\gac_32\system.enterpriseservices\2.0.0.0 _03f5f7f11d50a3a C:\WINDOWS\WinSxS\x86_System.EnterpriseServices03f5f7f11d50a3a_2.0.0.0_x-ww_7d5f3790

    Once the machine is booted, it will run the linkit.cmd, which will create the reparse point.
    If you want to be sure that the reparse point is successful, do the following:
    Get a dir of C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices
    In there, you should see:
    <JUNCTION> 2.0.0.0_03f5f7f11d50a3a

    This indicates that the reparse point was successful.

    for C:\WINDOWS\assembly\GAC_MSIL\IEExecRemote\2.0.0.0_03f5f7f11d50a3a, I think that the answer would be in C:\WINDOWS\WinSxS\MSIL_IEExecRemote03f5f7f11d50a3a_2.0.0.0_x-ww_6e57c34e.
    Just have to create the reparse point command as so:

    start /w c:\WINDOWS\RISupds\$OEM$\linkd.exe C:\WINDOWS\assembly\GAC_MSIL\IEExecRemote\2.0.0.0_03f5f7f11d50a3a C:\WINDOWS\WinSxS\MSIL_IEExecRemote03f5f7f11d50a3a_2.0.0.0_x-ww_6e57c34e

    Add that entry to the linkit.cmd and it should work out.

    I hope this helps, these riprep images can be a PITA.

    PM me your results!

    Laybackster


    Hawkz25 wrote:
    Hi guys,

    Im trying to upload an image to a RIS server and all of a sudden im getting the following errors

    Code:
    Can not copy reparse point: C:\WINDOWS\assembly\GAC_MSIL\IEExecRemote\2.0.0.0__b03f5f7f11d50a3a
    Error ignored. Operation continuing.
    
    Can not copy reparse point: C:\WINDOWS\assembly\GAC_32\System.EnterpriseServices\2.0.0.0__b03f5f7f11d50a3a
    Error ignored. Operation continuing.
    The lord Google does not reveal much information about this. The image is stuffed and i can't load them onto a new machine.

    I'm feeling very lost on this one.

    Previous happy images reveal that the second path doesn't exist, there is no 2.0.0... path. For the GAC_MSIL path, it is there and there is a file in the folder called IEEcecRemote.dll.

  3. Post
    #3
    thanks for that,

    as it happens these errors did not adversely affect the loading of the image onto a new computer, there must hav e been another problem causing my inital panic

    it's all good now though.

    thanks for your suggestion/solution laybackster, when I find time, I will look in to that further!