Results 1 to 4 of 4

  1. Post
    #1

    MSI x470 bios corrupted

    Hey guys, I've just pieced together my new Ryzen build with MSI x470 Gaming plus Mobo, while updating the bios had a system crash and now can't boot, suspect a corrupt bios.
    I purchased from amazon so MSI have been spectacularly unhelpful, my next option is to front up the shipping cost and send it back to the USA for RMA.
    Are there any easier solutions to get a bios refreshed on it in NZ, I don't really want to mess with desoldering a replacement chip
    Seems crazy to have bricked system just from a bios issue when motherboards have had dual bios for the last decade. Seems like there's a downside to not buying Gigabyte/Asus.

  2. Post
    #2
    If you got it through amazon and it is still in their return period they will usually pay return shipping

  3. Post
    #3
    Did you try update the BIOS from in windows? That is never a good idea if so.

    As for how to fix it, it might be worth googling your board and BIOS a bit. Some boards supported updating BIOS without a CPU installed. But i'm not sure if that works if the BIOS is corrupt or not. Good luck!

    There could even be an electronics place locally that can flash a BIOS on for you.
    Last edited by Fragluton; 10th January 2019 at 10:27 pm.

  4. Post
    #4
    Siris Le Osiris wrote:
    If you got it through amazon and it is still in their return period they will usually pay return shipping
    Thanks, I'll try get them to sort it. I would just return it for a refund as defective but I got it in Black Friday sale and the price was bloody good